SEO优化:如何解决WordPress更新和升级PHP后的主题错误

seo优化3个月前更新 xiaolin
37 0



WordPress升级PHP后,主题报告了一个错误,并显示以下错误消息:警告使用未定义的常量medium-假定为“medium”(这将在php的未来版本中引发错误)

此错误不会影响PHP函数,只会影响显示的错误。我们可以设置PHP来屏蔽这个错误。另一种方法是修改主题。如果可以,还可以修改主题。本节分享的内容是“WordPress升级PHP后的主题错误报告”。我希望这对你有帮助。

场景1:宝塔面板

使用宝塔面板的网站可以通过宝塔面板直接解决。在软件商店中找到WordPress使用的PHP,点击“配置修改”,找到“display_errors”,

然后单击“服务”并单击“重新启动”。单击“重新启动”时,必须确保单击它。如果页面没有响应,则不会单击。单击后,将出现提示,然后页面将自动刷新。

进行个人测试。之后,您可以解决WordPress的PHP版本过高并报告错误的问题。你不需要截屏。

案例2:修改php.ini

如果没有宝塔面板,我们需要找到php。ini,并按如下方式进行修改:

1.打开php.ini

2.设置错误报告=E_ALL ;~E_已弃用 ;~E_严格

3.设置display_errors=关闭

#免责声明#

本站提供的一切软件、教程和内容信息仅限用于学习和研究目的;不得将上述内容用于商业或者非法用途,否则,一切后果请用户自负。本站信息来自网络收集整理,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑或手机中彻底删除上述内容。如果您喜欢该程序和内容,请支持正版,购买注册,得到更好的正版服务。我们非常重视版权问题,如有侵权请邮件与我们联系处理。E-mail:487528908@qq.com 敬请谅解!

收藏
生成海报
点赞 (0)

© 版权声明

相关文章

暂无评论

暂无评论...